ae错误,光线跟踪3D:初始着色器编译失败的原因详解

2016-11-20 09:32

效果错误:光线跟踪3D:初始着色器编译失败。(5070 :: 0)的原因详解 当我在合成高级选项中更改为Ray-traced 3D后报错终于找到了原因。 经原作者同意,将原文翻译转载过来,有遇到同样错误的可以参考一下 ...

效果错误:光线跟踪3D:初始着色器编译失败。(5070 :: 0)的原因详解

 

当我在合成高级选项中更改为Ray-traced 3D后报错终于找到了原因。

经原作者同意,将原文翻译转载过来,有遇到同样错误的可以参考一下

AE错误,光线跟踪3D:初始着色器编译失败的原因详解_www.29jc.com
<点图片看大图>www.29jc.com

AE错误,光线跟踪3D:初始着色器编译失败的原因详解_www.29jc.com

AE错误,光线跟踪3D:初始着色器编译失败的原因详解_www.29jc.com
<点图片看大图>

效果错误:光线跟踪3D:初始着色器编译失败。(5070 :: 0)

如果你有,你不用担心,你并不孤单。

首先,我要说的是Adobe公司的光线跟踪渲染3D反应是,这是过时的和不正式支持。所以,不要找任何修复从Adobe的问题。

二,Adobe公司称在After Effects是建立在了Nvidia OptiX光线追踪引擎的光线跟踪渲染3D。NVIDIA GPU的支持CUDA可以加速这种发动机*,或者它可以在CPU上运行,但显然不是加速。其他的GPU不支持加速。

*内置到After Effects Optix公司的版本与最近NVIDIA GPU的兼容。这意味着使用麦克斯韦架构NVIDIA的显卡。

该GTX-750,GTX-750的Ti,GTX-960,GTX-970和GTX-980显卡。

这些显卡使用的是麦克斯韦架构构建。所以,我很抱歉地说,如果你有这些视频卡,您不能使用光线跟踪3D渲染引擎。这些新的基于麦克斯韦NVIDIA显卡不具备这是需要究其根源,3D渲染引擎的雷Optix公司库。如果您尝试使用GTX-750之一,GTX-750 Ti或GTX的900系列显卡,你只会得到“效果错误后:光线跟踪3D:初始着色器编译失败。(5070 :: 0)“的错误和几个其他错误的,当你试图实际使用使用光线跟踪3D渲染引擎。

Adobe公司已经捆绑的Cinema 4D精简版使用的影响后,以后的版本,这是您需要改为使用光线跟踪渲染3D的东西。

如果你没有这些卡之一,并仍然得到错误信息。

首先,确保你拥有所有的安装后更新的影响。这是重要的,因为Adobe已经作出许多修正,包括那些将允许更多的视频卡使用光线跟踪三维渲染引擎,特别是与后对CS6。

其次,后对CS6(11.0)和CC(12.0),后效应有视频卡列表,Adobe已经测试或批准。如果你的显卡是不是这个名单上,你去选择GPU,发现它灰色的,这不是我们只会增加您的显卡到列表中的一个问题。我会告诉你如何在文章中有点远了。

三,如果你正在使用效果CC(12.1)之后,或者影响CC 2014后,Adobe已经加入该复选框- “启用光线跟踪渲染3D的CUDA加速未经测试,不受支持的GPU”

来吧,只要勾选框或按照以下步骤将视频卡添加到批准的视频卡列表。无论哪种方式,后效应将允许您使用光线跟踪三维渲染引擎将使用您的视频卡。

raytracer_supported_cards.txt文件

After Effects中有一个包含视频卡的列表称为raytracer_supported_cards.txt的文本文件。这个名单告诉该卡使用“认证的”或已批准的由Adobe After Effects的影响后。

我写了一个节目叫cuda.bat创建一个包含所有NVIDIA显卡新raytracer_supported_cards.txt文件。这样,您就可以使用您的视频卡的Adobe是否已批准它。

你也可以编辑这个文本文件,并添加自己的视频卡到列表中。这是比较容易只使用该程序,这样你就不必担心会拼写或大小写正确。

注意:即使你添加GTX-750,GTX-750 Ti或的GTX-900系列显卡之一,你仍然会得到“效果错误后:光线跟踪3D:初始着色器编译失败。(5070 :: 0)“的错误,因为这些视频卡使用的麦克斯韦架构构建,不会与后效应工作,即使视频卡被添加到raytracer_supported_cards.txt文件。

如何将您的视频卡添加到raytracer_supported_cards.txt

你读完之后此页转到:
https://www.studio1productions.com/Articles/AfterEffects.htm

近在页面左侧的文章的末尾,你会发现在自动方法程序CUDA.BAT添加您的显卡到raytracer_supported_cards.txt文件。

而在网页的右侧,你会发现一步一步的指示,以你的卡手动添加到列表中raytracer_supported_cards.txt文件。

您必须按照说明操作,否则将无法正常工作。这就是为什么我写的程序,使其更容易为大家做。


什么显卡的Adobe没有批准?

这是其中的Adobe已经认证或批准后,在Windows上影响显卡列表:

GeForce GTX 285
GeForce GTX 470
GeForce GTX 570
GeForce GTX 580
GeForce GTX 590
GeForce GTX 670
GeForce GTX 675MX
GeForce GTX 680
GeForce GTX 680MX
GeForce GTX 690
GeForce GTX 760
GeForce GTX 770
GeForce GTX 780
GeForce GTX TITAN
GeForce GT 650M
Quadro CX
Quadro FX 3700M
Quadro FX 3800
Quadro FX 3800M
Quadro FX 4800
Quadro FX 5800
Quadro 2000
Quadro 2000D
Quadro 2000M
Quadro 3000M
Quadro 4000
Quadro 4000M
Quadro 5000
Quadro 5000M
Quadro 5010M
Quadro 6000
Quadro K2000
Quadro K2100M
Quadro K3000M
Quadro K3100M
Quadro K4000
Quadro K4000M
Quadro K4100M
Quadro K5000
Quadro K5000M
Quadro K5100M
Quadro K6000
特斯拉C2075

只要记住,如果你的显卡是不是在此列表中,您可以将其添加到列表中,以便您可以使用光线跟踪在After Effects 3D渲染引擎。

我曾尝试GTX-650TI,GTX-660,GTX-760和After Effects的CS6和CC的影响2014年之后,我不得不使用3D究其根源渲染引擎雷没有问题的GTX-770显卡。我所做的只是我的视频卡添加的名字与我写的程序raytracer_supported_cards.txt文件。

最后请注意

我见过一些YouTube视频,而该人说,他们对于GTX 900系列显卡的修复程序。他们的解决办法是简单地将显卡添加到raytracer_supported_cards.txt文件,并再忽略“After Effects的错误:光线跟踪3D:初始着色器编译失败。(5070 :: 0)“错误消息。

然后,他们会告诉你,你可以设置光线跟踪三维渲染引擎的GPU。问题是,当你真正尝试使用3D究其根源,渲染引擎,你会得到同样的错误信息和其他几个错误雷,它根本不起作用。

 

全教程完,学完记得交作业。如果本教程对您有所帮助,请推荐给你的朋友。

关注我们新浪官方认证微博,随时随地,想学就能学!新浪认证微博:http://weibo.com/u/3928837770
关闭

站长推荐 上一条 /1 下一条



Powered by Discuz! X3.4© 2001-2013 Comsenz Inc.( 桂ICP备12007517号-1 )